dev-java/jdbc-mysql: update homepage
[gentoo.git] / dev-java / commons-vfs / commons-vfs-2.0-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-ant-2
9
10 DESCRIPTION="A single API for accessing various different file systems"
11 HOMEPAGE="http://commons.apache.org/vfs/"
12 SRC_URI="mirror://apache/commons/vfs/source/${P}-src.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="2"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17
18 CDEPEND="
19         dev-java/ant-core:0
20         dev-java/commons-collections:0
21         dev-java/commons-logging:0
22         dev-java/commons-net:0
23         dev-java/commons-httpclient:3
24         dev-java/jackrabbit-webdav:0
25         dev-java/jsch:0
26         "
27
28 RDEPEND=">=virtual/jre-1.6
29         ${CDEPEND}"
30
31 DEPEND=">=virtual/jdk-1.6
32         ${CDEPEND}"
33
34 S="${WORKDIR}/${P}/core"
35
36 java_prepare() {
37         epatch "${FILESDIR}"/${P}-incompatibility.patch
38
39         cp "${FILESDIR}"/${P}-build.xml build.xml || die
40
41         java-ant_rewrite-classpath
42         java-ant_ignore-system-classes
43 }
44
45 EANT_GENTOO_CLASSPATH="
46         ant-core
47         commons-collections
48         commons-logging
49         commons-net
50         commons-httpclient-3
51         jackrabbit-webdav
52         jsch
53 "
54 EANT_EXTRA_ARGS="-Dlibdir=${T}"
55
56 # The build.xml is generated from maven and can't run the tests properly
57 # Use maven test to execute these manually but that means downloading deps from
58 # the internet. Also the tests need to login to some ftp servers and samba
59 # shares so I doubt they work for everyone.
60 #src_test() {
61 #       ANT_TASKS="ant-junit" eant test
62 #}
63
64 src_install() {
65         java-pkg_newjar target/*.jar
66
67         use doc && java-pkg_dojavadoc target/site/apidocs
68         use source && java-pkg_dosrc src/main/java
69 }