Merge remote-tracking branch 'github/pr/708'.
[gentoo.git] / dev-java / commons-net / commons-net-1.4.1-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 JAVA_PKG_IUSE="doc examples source" # junit
6
7 inherit eutils java-pkg-2 java-ant-2
8
9 MY_P="${P}-src"
10 DESCRIPTION="The purpose of the library is to provide fundamental protocol access, not higher-level abstractions"
11 HOMEPAGE="http://commons.apache.org/net/"
12 SRC_URI="mirror://apache/jakarta/commons/net/source/${MY_P}.tar.gz"
13
14 # dev-java/oro had a package move to jakarta-oro so depend on a version
15 # that oro did not have. Most likely the cause of https://bugs.gentoo.org/show_bug.cgi?id=183595
16 COMMON_DEP="
17         >=dev-java/jakarta-oro-2.0.8-r2"
18 RDEPEND=">=virtual/jre-1.3
19         ${COMMON_DEP}
20         "
21 DEPEND=">=virtual/jdk-1.3
22         ${COMMON_DEP}"
23 LICENSE="Apache-2.0"
24 SLOT="0"
25 KEYWORDS="amd64 ppc64 x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
26 IUSE=""
27
28 # disabling unit tests:
29 # http://issues.apache.org/bugzilla/show_bug.cgi?id=37985
30 RESTRICT="test"
31
32 src_unpack() {
33         unpack ${A}
34         cd "${S}"
35         mkdir -p target/lib
36         cd target/lib
37         java-pkg_jar-from jakarta-oro-2.0 jakarta-oro.jar oro.jar
38
39         cd "${S}"
40         # always disable tests
41         sed -i 's/depends="compile,test"/depends="compile"/' build.xml || die "Failed to disable junit"
42 }
43
44 src_install() {
45         java-pkg_newjar target/${P}.jar ${PN}.jar
46
47         use doc && java-pkg_dojavadoc dist/docs/api
48         use examples && java-pkg_doexamples src/java/examples
49         use source && java-pkg_dosrc src/java/org
50 }