dev-java/openjdk: remove unused generate-cacerts.pl
[gentoo.git] / dev-java / commons-math / commons-math-3.6.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 JAVA_PKG_IUSE="doc examples source"
7
8 inherit java-pkg-2 java-pkg-simple
9
10 MY_PN="${PN}3"
11 MY_P="${MY_PN}-${PV}"
12
13 DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
14 HOMEPAGE="https://commons.apache.org/math/"
15 SRC_URI="https://repo1.maven.org/maven2/org/apache/commons/${MY_PN}/${PV}/${MY_P}-sources.jar
16 -> ${MY_P}.jar"
17
18 DEPEND=">=virtual/jdk-1.6"
19 RDEPEND=">=virtual/jre-1.6"
20
21 LICENSE="Apache-2.0"
22 SLOT="0"
23 KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"