dev-java/openjdk: remove unused generate-cacerts.pl
[gentoo.git] / dev-java / commons-math / commons-math-2.1-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 JAVA_PKG_IUSE="doc test source"
7
8 inherit java-pkg-2 java-ant-2
9
10 DESCRIPTION="Lightweight, self-contained mathematics and statistics components"
11 HOMEPAGE="https://commons.apache.org/math/"
12 SRC_URI="mirror://apache/commons/math/source/${P}-src.tar.gz"
13 LICENSE="Apache-2.0"
14 SLOT="2"
15 KEYWORDS="amd64 x86"
16
17 DEPEND="
18         >=virtual/jdk-1.6
19         test? (
20                 dev-java/ant-junit4
21                 dev-java/hamcrest-core:0
22         )"
23
24 RDEPEND="
25         >=virtual/jre-1.6"
26
27 S="${WORKDIR}/${P}-src"
28
29 PATCHES=( "${FILESDIR}"/${PF}-buildfixes.patch )
30
31 src_test() {
32         java-pkg_jar-from junit-4
33         java-pkg_jar-from hamcrest-core
34         ANT_TASKS="ant-junit4" eant -Djunit.jar=junit.jar test
35 }
36
37 src_install() {
38         java-pkg_newjar target/${P}.jar ${PN}.jar
39
40         use doc && java-pkg_dojavadoc target/apidocs
41         use source && java-pkg_dosrc src/main/java/org
42 }