dev-java/openjdk-bin: amd64 stable wrt bug #718720
[gentoo.git] / dev-java / commons-lang / commons-lang-3.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 JAVA_PKG_IUSE="doc source test"
6
7 inherit java-pkg-2 java-ant-2
8
9 MY_P="${PN}3-${PV}"
10
11 DESCRIPTION="Commons components to manipulate core java classes"
12 HOMEPAGE="http://commons.apache.org/lang/"
13 SRC_URI="mirror://apache/commons/lang/source/${MY_P}-src.tar.gz"
14
15 DEPEND=">=virtual/jdk-1.5
16         test? ( dev-java/ant-junit:0 )"
17
18 RDEPEND=">=virtual/jre-1.5"
19
20 LICENSE="Apache-2.0"
21 SLOT="3.1"
22 KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris"
23
24 S="${WORKDIR}/${MY_P}-src"
25
26 JAVA_ANT_ENCODING="ISO-8859-1"
27
28 src_install() {
29         java-pkg_newjar target/${MY_P}.jar ${PN}.jar
30
31         dodoc RELEASE-NOTES.txt NOTICE.txt
32
33         use doc && java-pkg_dojavadoc target/apidocs
34         use source && java-pkg_dosrc src/main/java/*
35 }