dev-java/openjdk-bin: amd64 stable wrt bug #718720
[gentoo.git] / dev-java / commons-lang / commons-lang-2.6-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 JAVA_PKG_IUSE="doc source test"
6
7 inherit java-pkg-2 java-ant-2
8
9 DESCRIPTION="Commons components to manipulate core java classes"
10 HOMEPAGE="http://commons.apache.org/lang/"
11 SRC_URI="mirror://apache/commons/lang/source/${P}-src.tar.gz"
12
13 LICENSE="Apache-2.0"
14 KEYWORDS="amd64 ~arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris"
15 SLOT="2.1"
16 IUSE=""
17
18 DEPEND=">=virtual/jdk-1.4
19         test? (
20                 dev-java/ant-junit:0
21         )"
22
23 RDEPEND=">=virtual/jre-1.4"
24
25 S="${WORKDIR}/${P}-src"
26
27 JAVA_ANT_ENCODING="ISO-8859-1"
28
29 src_install() {
30         java-pkg_newjar "target/${P}.jar" "${PN}.jar"
31         dodoc RELEASE-NOTES.txt NOTICE.txt
32         dohtml *.html
33         use doc && java-pkg_dojavadoc target/apidocs
34         use source && java-pkg_dosrc src/main/java/*
35 }