dev-java/openjdk-bin: amd64 stable wrt bug #718720
[gentoo.git] / dev-java / commons-lang / commons-lang-2.0-r3.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 JAVA_PKG_IUSE="doc source test"
6
7 inherit java-pkg-2 java-ant-2
8
9 DESCRIPTION="Jakarta components to manipulate core java classes"
10 HOMEPAGE="http://commons.apache.org/lang/"
11 SRC_URI="mirror://apache/jakarta/commons/lang/source/${P}-src.tar.gz"
12 DEPEND=">=virtual/jdk-1.4
13         test? ( dev-java/ant-junit )"
14 RDEPEND=">=virtual/jre-1.4"
15 LICENSE="Apache-1.1"
16 SLOT="0"
17 KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
18 IUSE=""
19
20 S="${WORKDIR}/${P}-src"
21
22 java_prepare() {
23         java-pkg_clean
24 }
25
26 src_install() {
27         java-pkg_newjar dist/${P}.jar ${PN}.jar
28
29         dodoc RELEASE-NOTES.txt
30         java-pkg_dohtml DEVELOPERS-GUIDE.html PROPOSAL.html STATUS.html
31         use doc && java-pkg_dojavadoc dist/docs/api
32         use source && java-pkg_dosrc src/java/*
33 }