sys-libs/libnih: stable 1.0.3-r4 for hppa, bug #724174
[gentoo.git] / dev-java / commons-graph / commons-graph-0.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 JAVA_PKG_IUSE="doc source test"
6
7 inherit java-pkg-2 java-ant-2
8
9 DESCRIPTION="A toolkit for managing graphs and graph based data structures"
10 HOMEPAGE="https://commons.apache.org/sandbox/commons-graph/"
11 SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE=""
16
17 DEPEND=">=virtual/jdk-1.6
18         test? (
19                 dev-java/ant-junit:0
20         )"
21
22 RDEPEND=">=virtual/jre-1.6
23         ${CDEPEND}"
24
25 JAVA_ANT_REWRITE_CLASSPATH="yes"
26 EANT_TEST_TARGET="test"
27
28 # Dubious tests.
29 JAVA_RM_FILES=(
30         src/test/java/org/apache/commons/graph/coloring/GraphColoringTestCase.java
31         src/test/java/org/apache/commons/graph/spanning/KruskalTestCase.java
32         src/test/java/org/apache/commons/graph/scc/TarjanTestCase.java
33 )
34
35 java_prepare() {
36         cp "${FILESDIR}"/"${P}-build.xml" build.xml || die
37 }
38
39 src_test() {
40         java-pkg-2_src_test
41 }
42
43 src_install() {
44         java-pkg_newjar target/${P}.jar
45         use doc && java-pkg_dojavadoc target/site/apidocs
46         use source && java-pkg_dosrc src/main/java
47 }