dev-java/icedtea-bin: 3.15.0 ppc64 stable, bug #705992
[gentoo.git] / dev-java / commons-digester / commons-digester-1.8.1-r2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 JAVA_PKG_IUSE="doc examples source test"
6
7 inherit eutils java-pkg-2 java-ant-2
8
9 MY_P="${P}-src"
10 DESCRIPTION="Reads XML configuration files to provide initialization of various Java objects"
11 HOMEPAGE="http://commons.apache.org/digester/"
12 SRC_URI="mirror://apache/commons/digester/source/${MY_P}.tar.gz"
13
14 LICENSE="Apache-2.0"
15 SLOT="0"
16 KEYWORDS="amd64 ppc64 x86"
17 IUSE=""
18
19 CDEPEND="dev-java/commons-beanutils:1.7
20         >=dev-java/commons-collections-2.1:0
21         >=dev-java/commons-logging-1.0.2:0"
22 RDEPEND=">=virtual/jre-1.6
23         ${CDEPEND}"
24 DEPEND=">=virtual/jdk-1.6
25         test? (
26                 dev-java/junit:0
27                 dev-java/ant-junit:0
28         )
29         ${CDEPEND}"
30
31 S="${WORKDIR}/${P}-src"
32
33 # don't rewrite build.xml in examples
34 JAVA_PKG_BSFIX_ALL="no"
35
36 JAVA_ANT_REWRITE_CLASSPATH="true"
37 EANT_GENTOO_CLASSPATH="commons-beanutils-1.7,commons-collections,commons-logging"
38
39 java_prepare() {
40         epatch "${FILESDIR}/${PV}-build.xml-jar-target.patch"
41 }
42
43 EANT_TEST_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH},junit"
44
45 src_test() {
46         java-pkg-2_src_test
47 }
48
49 src_install() {
50         java-pkg_dojar "dist/${PN}.jar"
51
52         dodoc RELEASE-NOTES.txt
53
54         use doc && java-pkg_dojavadoc dist/docs/api
55         use source && java-pkg_dosrc src/java/org
56         use examples && java-pkg_doexamples src/examples
57 }