dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-java / commons-configuration / commons-configuration-1.6-r2.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 JAVA_PKG_IUSE="doc source"
7
8 inherit eutils java-pkg-2 java-ant-2
9
10 DESCRIPTION="Generic interface for reading configuration data from a variety of sources"
11 HOMEPAGE="http://commons.apache.org/configuration/"
12 SRC_URI="mirror://apache/commons/configuration/source/${P}-src.tar.gz"
13
14 # it needs functionality from ant-core, although not providing an ant task
15 # the functionality is apparently needed only for 1.4 jdk
16 # but I don't feel like adding virtual for this
17 CDEPEND="
18         >=dev-java/commons-beanutils-1.7.0:1.7
19         >=dev-java/commons-codec-1.3:0
20         >=dev-java/commons-collections-3.1:0
21         >=dev-java/commons-digester-1.8:0
22         >=dev-java/commons-jxpath-1.2:0
23         >=dev-java/commons-lang-2.4:2.1
24         >=dev-java/commons-logging-1.1.1:0
25         java-virtuals/servlet-api:3.0
26         dev-java/ant-core:0"
27
28 DEPEND=">=virtual/jdk-1.6
29         ${CDEPEND}"
30 RDEPEND=">=virtual/jre-1.6
31         ${CDEPEND}"
32 LICENSE="Apache-2.0"
33 SLOT="0"
34
35 KEYWORDS="amd64 ppc64 x86"
36 IUSE=""
37
38 S="${WORKDIR}/${P}-src"
39
40 JAVA_ANT_REWRITE_CLASSPATH="yes"
41
42 java_prepare() {
43         # Tweak build classpath and don't automatically run tests
44         epatch "${FILESDIR}/${P}-gentoo.patch"
45 }
46
47 EANT_GENTOO_CLASSPATH="
48         commons-beanutils-1.7
49         commons-codec
50         commons-collections
51         commons-digester
52         commons-jxpath
53         commons-lang-2.1
54         commons-logging
55         servlet-api-3.0
56         ant-core"
57
58 # Would need mockobjects with j2ee support which we don't have
59 # Check overlay for ebuild with test support
60 RESTRICT="test"
61
62 src_install() {
63         java-pkg_newjar target/${P}.jar
64         dodoc RELEASE-NOTES.txt
65         use doc && java-pkg_dohtml -r dist/docs/api
66         use source && java-pkg_dosrc src/java/*
67 }