dev-java/tomcat-servlet-api: amd64 stable wrt bug #718018
[gentoo.git] / dev-java / asm / asm-5.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 OLD_P="${PN}-4.0"
6 JAVA_PKG_IUSE="doc source"
7
8 inherit java-pkg-2 java-ant-2
9
10 DESCRIPTION="Bytecode manipulation framework for Java"
11 HOMEPAGE="http://asm.ow2.org"
12 SRC_URI="http://download.forge.objectweb.org/${PN}/${P}.tar.gz
13         http://download.forge.objectweb.org/${PN}/${OLD_P}.tar.gz"
14 LICENSE="BSD"
15 SLOT="4"
16 IUSE=""
17 KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~x64-macos"
18
19 DEPEND=">=virtual/jdk-1.6"
20 RDEPEND=">=virtual/jre-1.6"
21
22 # Needs dependencies we don't have yet.
23 RESTRICT="test"
24
25 EANT_DOC_TARGET="jdoc"
26
27 # Fails if this objectweb.ant.tasks.path is not set.
28 # Java generics seem to break unless product.noshrink is set.
29 EANT_EXTRA_ARGS="-Dobjectweb.ant.tasks.path=foobar -Dproduct.noshrink=true"
30
31 java_prepare() {
32         # Borrow some ant scripts from an old version to avoid requiring
33         # bndlib and friends. This may not work forever!
34         cp -vf "../${OLD_P}/archive"/*.xml archive/ || die
35 }
36
37 src_install() {
38         for x in output/dist/lib/*.jar ; do
39                 java-pkg_newjar "${x}" $(basename "${x%-*}.jar")
40         done
41
42         use doc && java-pkg_dojavadoc output/dist/doc/javadoc/user/
43         use source && java-pkg_dosrc src/*
44 }