dev-java/tomcat-servlet-api: amd64 stable wrt bug #718018
[gentoo.git] / dev-java / ant-owanttask / ant-owanttask-1.3.2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit java-pkg-2 java-ant-2
7
8 DESCRIPTION="ObjectWeb's Ant tasks"
9 HOMEPAGE="http://monolog.objectweb.org"
10 SRC_URI="http://download.forge.objectweb.org/monolog/ow_util_ant_tasks_${PV}.zip"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
15
16 COMMON_DEP="dev-java/xalan"
17 DEPEND=">=virtual/jdk-1.4
18         ${COMMON_DEP}"
19 RDEPEND=">=virtual/jre-1.4
20         >=dev-java/ant-core-1.7.0
21         ${COMMON_DEP}"
22
23 S=${WORKDIR}
24
25 src_prepare() {
26         rm -f output/lib/*.jar
27 }
28
29 src_install() {
30         java-pkg_dojar output/lib/ow_util_ant_tasks.jar
31 }
32
33 pkg_postinst() {
34         ewarn "The MultipleCopy task is not compatible with ant-1.7.0 and newer"
35         ewarn "Attempt to use it will break building."
36 }