dev-java/tomcat-servlet-api: bump to 8.5.55
[gentoo.git] / dev-java / animal-sniffer-annotations / animal-sniffer-annotations-1.15.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_PN="${PN%-annotations}"
7 JAVA_PKG_IUSE="doc source"
8
9 inherit java-pkg-2 java-pkg-simple
10
11 DESCRIPTION="Java annotations for marking methods that Animal Sniffer should ignore"
12 HOMEPAGE="http://www.mojohaus.org/animal-sniffer/animal-sniffer-annotations/"
13 SRC_URI="https://github.com/mojohaus/${MY_PN}/archive/${MY_PN}-parent-${PV}.tar.gz"
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="amd64 ~arm64 x86"
17
18 DEPEND=">=virtual/jdk-1.7"
19 RDEPEND=">=virtual/jre-1.7"
20
21 S="${WORKDIR}/${MY_PN}-${MY_PN}-parent-${PV}/${PN}"
22 JAVA_SRC_DIR="src/main/java"