www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / dev-haskell / zlib-enum / zlib-enum-0.2.3.1-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.9999
7 #hackport: flags: -test
8
9 CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 DESCRIPTION="Enumerator interface for zlib compression"
13 HOMEPAGE="https://github.com/maltem/zlib-enum"
14 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RDEPEND=">=dev-haskell/enumerator-0.4:=[profile?] <dev-haskell/enumerator-0.5:=[profile?]
22         >=dev-haskell/transformers-0.2:=[profile?]
23         >=dev-haskell/zlib-bindings-0.1:=[profile?] <dev-haskell/zlib-bindings-0.2:=[profile?]
24         >=dev-lang/ghc-7.4.1:=
25 "
26 DEPEND="${RDEPEND}
27         >=dev-haskell/cabal-1.6
28 "
29
30 src_prepare() {
31         cabal_chdeps \
32                 'transformers          >= 0.2 && < 0.5' 'transformers          >= 0.2' \
33                 'transformers               >= 0.2      &&   < 0.5' 'transformers               >= 0.2'
34 }
35
36 src_configure() {
37         haskell-cabal_src_configure \
38                 --flag=-test
39 }