dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-haskell / zlib-conduit / zlib-conduit-1.0.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.3.2.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="Streaming compression/decompression via conduits"
12 HOMEPAGE="https://github.com/snoyberg/conduit"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+debug"
19
20 RDEPEND="=dev-haskell/conduit-1.0*:=[profile?]
21                 >=dev-haskell/transformers-0.2.2:=[profile?]
22                 <dev-haskell/transformers-0.4:=[profile?]
23                 dev-haskell/void:=[profile?]
24                 =dev-haskell/zlib-bindings-0.1*:=[profile?]
25                 >=dev-lang/ghc-6.10.4:="
26 DEPEND="${RDEPEND}
27                 >=dev-haskell/cabal-1.8
28                 test? ( >=dev-haskell/hspec-1.3
29                         dev-haskell/quickcheck
30                         dev-haskell/resourcet
31                 )"
32
33 src_configure() {
34         haskell-cabal_src_configure \
35                 $(cabal_flag debug debug)
36 }