*/*: Drop stable ia64 keywords
[gentoo.git] / dev-haskell / yesod-auth / yesod-auth-1.4.13.5.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.5.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
10
11 DESCRIPTION="Authentication for Yesod"
12 HOMEPAGE="https://www.yesodweb.com/"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+network-uri"
19
20 RDEPEND=">=dev-haskell/aeson-0.7:=[profile?]
21         >=dev-haskell/authenticate-1.3:=[profile?]
22         dev-haskell/base16-bytestring:=[profile?]
23         dev-haskell/base64-bytestring:=[profile?]
24         dev-haskell/binary:=[profile?]
25         dev-haskell/blaze-builder:=[profile?]
26         >=dev-haskell/blaze-html-0.5:=[profile?]
27         >=dev-haskell/blaze-markup-0.5.1:=[profile?]
28         dev-haskell/byteable:=[profile?]
29         dev-haskell/conduit:=[profile?]
30         dev-haskell/conduit-extra:=[profile?]
31         dev-haskell/cryptohash:=[profile?]
32         dev-haskell/data-default:=[profile?]
33         >=dev-haskell/email-validate-1.0:=[profile?]
34         dev-haskell/file-embed:=[profile?]
35         dev-haskell/http-client:=[profile?]
36         >=dev-haskell/http-conduit-2.1:=[profile?]
37         dev-haskell/http-types:=[profile?]
38         >=dev-haskell/lifted-base-0.1:=[profile?]
39         >=dev-haskell/mime-mail-0.3:=[profile?]
40         >=dev-haskell/nonce-1.0.2:=[profile?] <dev-haskell/nonce-1.1:=[profile?]
41         >=dev-haskell/persistent-2.1:=[profile?] <dev-haskell/persistent-2.7:=[profile?]
42         >=dev-haskell/persistent-template-2.1:=[profile?] <dev-haskell/persistent-template-2.7:=[profile?]
43         >=dev-haskell/random-1.0.0.2:=[profile?]
44         dev-haskell/resourcet:=[profile?]
45         dev-haskell/safe:=[profile?]
46         dev-haskell/shakespeare:=[profile?]
47         >=dev-haskell/text-0.7:=[profile?]
48         >=dev-haskell/transformers-0.2.2:=[profile?]
49         dev-haskell/unordered-containers:=[profile?]
50         >=dev-haskell/wai-1.4:=[profile?]
51         >=dev-haskell/yesod-core-1.4.20:=[profile?] <dev-haskell/yesod-core-1.5:=[profile?]
52         >=dev-haskell/yesod-form-1.4:=[profile?] <dev-haskell/yesod-form-1.5:=[profile?]
53         >=dev-haskell/yesod-persistent-1.4:=[profile?]
54         >=dev-lang/ghc-7.4.1:=
55         network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
56         !network-uri? ( <dev-haskell/network-2.6:=[profile?] )
57 "
58 DEPEND="${RDEPEND}
59         >=dev-haskell/cabal-1.6.0
60 "
61
62 src_configure() {
63         haskell-cabal_src_configure \
64                 $(cabal_flag network-uri network-uri)
65 }