dev-haskell/yaml: bump up to 0.8.21.2
[gentoo.git] / dev-haskell / yaml / yaml-0.8.20.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 # ebuild generated by hackport 0.5.9999
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 DESCRIPTION="Support for parsing and rendering YAML documents"
13 HOMEPAGE="https://github.com/snoyberg/yaml/"
14 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="+no-examples no-exe no-unicode system-libyaml"
20
21 RDEPEND=">=dev-haskell/aeson-0.7:=[profile?]
22         >=dev-haskell/attoparsec-0.11.3.0:=[profile?]
23         >=dev-haskell/conduit-1.1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
24         dev-haskell/enclosed-exceptions:=[profile?]
25         >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
26         dev-haskell/scientific:=[profile?]
27         dev-haskell/semigroups:=[profile?]
28         dev-haskell/text:=[profile?]
29         dev-haskell/unordered-containers:=[profile?]
30         dev-haskell/vector:=[profile?]
31         >=dev-lang/ghc-7.8.2:=
32         !no-examples? ( dev-haskell/raw-strings-qq:=[profile?] )
33         system-libyaml? ( dev-libs/libyaml )
34 "
35 DEPEND="${RDEPEND}
36         >=dev-haskell/cabal-1.18.1.3
37         test? ( dev-haskell/aeson-qq
38                 dev-haskell/base-compat
39                 >=dev-haskell/hspec-1.3
40                 dev-haskell/hunit
41                 dev-haskell/mockery
42                 dev-haskell/temporary )
43         system-libyaml? ( virtual/pkgconfig )
44 "
45
46 src_configure() {
47         haskell-cabal_src_configure \
48                 $(cabal_flag no-examples no-examples) \
49                 $(cabal_flag no-exe no-exe) \
50                 $(cabal_flag no-unicode no-unicode) \
51                 $(cabal_flag system-libyaml system-libyaml)
52 }