dev-haskell/colour: bump up to 2.3.5
[gentoo.git] / dev-haskell / xss-sanitize / xss-sanitize-0.3.5.6.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.5.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="sanitize untrusted HTML to prevent XSS attacks"
12 HOMEPAGE="https://github.com/yesodweb/haskell-xss-sanitize"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+network-uri"
19
20 RDEPEND=">=dev-haskell/attoparsec-0.10.0.3:=[profile?] <dev-haskell/attoparsec-1:=[profile?]
21         >=dev-haskell/css-text-0.1.1:=[profile?] <dev-haskell/css-text-0.2:=[profile?]
22         >=dev-haskell/tagsoup-0.12.2:=[profile?] <dev-haskell/tagsoup-1:=[profile?]
23         >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-2:=[profile?]
24         >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
25         >=dev-lang/ghc-7.4.1:=
26         network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
27         !network-uri? ( <dev-haskell/network-2.6:=[profile?] )
28 "
29 DEPEND="${RDEPEND}
30         >=dev-haskell/cabal-1.8
31         test? ( >=dev-haskell/hspec-1.3
32                 >=dev-haskell/hunit-1.2 )
33 "
34
35 src_configure() {
36         haskell-cabal_src_configure \
37                 $(cabal_flag network-uri network-uri)
38 }