dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-haskell / xml-conduit / xml-conduit-1.1.0.9.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.3.5.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="Pure-Haskell utilities for dealing with XML with the conduit package"
12 HOMEPAGE="https://github.com/snoyberg/xml"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?]
21         >=dev-haskell/attoparsec-conduit-1.0:=[profile?]
22         >=dev-haskell/blaze-builder-0.2:=[profile?] <dev-haskell/blaze-builder-0.4:=[profile?]
23         >=dev-haskell/blaze-builder-conduit-1.0:=[profile?]
24         >=dev-haskell/blaze-html-0.5:=[profile?]
25         >=dev-haskell/blaze-markup-0.5:=[profile?]
26         >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.1:=[profile?]
27         dev-haskell/data-default:=[profile?]
28         >=dev-haskell/failure-0.1:=[profile?] <dev-haskell/failure-0.3:=[profile?]
29         >=dev-haskell/monad-control-0.3:=[profile?] <dev-haskell/monad-control-0.4:=[profile?]
30         >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-0.5:=[profile?]
31         >=dev-haskell/system-filepath-0.4:=[profile?] <dev-haskell/system-filepath-0.5:=[profile?]
32         >=dev-haskell/text-0.7:=[profile?]
33         >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
34         >=dev-haskell/xml-types-0.3.4:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
35         >=dev-lang/ghc-7.4.1:=
36 "
37 DEPEND="${RDEPEND}
38         >=dev-haskell/cabal-1.8
39         test? ( >=dev-haskell/hspec-1.3
40                 dev-haskell/hunit )
41 "