Merge remote-tracking branch 'github/pr/674'.
[gentoo.git] / dev-haskell / x509-validation / x509-validation-1.5.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.5.9999
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 DESCRIPTION="X.509 Certificate and CRL validation"
13 HOMEPAGE="https://github.com/vincenthz/hs-certificate"
14 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="amd64 x86"
19 IUSE=""
20
21 RDEPEND=">=dev-haskell/asn1-encoding-0.9:=[profile?] <dev-haskell/asn1-encoding-0.10:=[profile?]
22         >=dev-haskell/asn1-types-0.3:=[profile?] <dev-haskell/asn1-types-0.4:=[profile?]
23         dev-haskell/byteable:=[profile?]
24         >=dev-haskell/crypto-pubkey-0.1.4:=[profile?] <dev-haskell/crypto-pubkey-0.3:=[profile?]
25         >=dev-haskell/crypto-pubkey-types-0.4:=[profile?] <dev-haskell/crypto-pubkey-types-0.5:=[profile?]
26         >=dev-haskell/cryptohash-0.9:=[profile?] <dev-haskell/cryptohash-0.12:=[profile?]
27         dev-haskell/data-default-class:=[profile?]
28         dev-haskell/hourglass:=[profile?]
29         dev-haskell/mtl:=[profile?]
30         dev-haskell/network:=[profile?]
31         >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
32         >=dev-haskell/x509-1.5.0:=[profile?] <dev-haskell/x509-1.6:=[profile?]
33         >=dev-haskell/x509-store-1.5:=[profile?] <dev-haskell/x509-store-1.6:=[profile?]
34         >=dev-lang/ghc-7.4.1:=
35 "
36 DEPEND="${RDEPEND}
37         >=dev-haskell/cabal-1.6
38 "