dev-haskell/syb: bump up to 0.7.1
[gentoo.git] / dev-haskell / x509-store / x509-store-1.5.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.3
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
10
11 DESCRIPTION="X.509 collection accessing and storing methods"
12 HOMEPAGE="https://github.com/vincenthz/hs-certificate"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="executable test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND=">=dev-haskell/asn1-encoding-0.9:=[profile?] <dev-haskell/asn1-encoding-0.10:=[profile?]
22         >=dev-haskell/asn1-types-0.3:=[profile?] <dev-haskell/asn1-types-0.4:=[profile?]
23         >=dev-haskell/crypto-pubkey-types-0.3:=[profile?] <dev-haskell/crypto-pubkey-types-0.5:=[profile?]
24         dev-haskell/mtl:=[profile?]
25         >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
26         >=dev-haskell/x509-1.5.0:=[profile?] <dev-haskell/x509-1.6:=[profile?]
27         >=dev-lang/ghc-7.4.1:=
28 "
29 DEPEND="${RDEPEND}
30         >=dev-haskell/cabal-1.8
31 "
32
33 src_configure() {
34         haskell-cabal_src_configure \
35                 $(cabal_flag executable executable) \
36                 $(cabal_flag test test)
37 }