Merge the GLEP 67 transition changes
[gentoo.git] / dev-haskell / wai-extra / wai-extra-3.0.14.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.6.9999
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 DESCRIPTION="Provides some basic WAI handlers and middleware"
13 HOMEPAGE="https://github.com/yesodweb/wai"
14 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
15
16 LICENSE="MIT"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RDEPEND="dev-haskell/aeson:=[profile?]
22         dev-haskell/ansi-terminal:=[profile?]
23         dev-haskell/base64-bytestring:=[profile?]
24         >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
25         >=dev-haskell/case-insensitive-0.2:=[profile?]
26         dev-haskell/cookie:=[profile?]
27         dev-haskell/data-default-class:=[profile?]
28         >=dev-haskell/fast-logger-2.1:=[profile?] <dev-haskell/fast-logger-2.5:=[profile?]
29         >=dev-haskell/http-types-0.7:=[profile?]
30         dev-haskell/iproute:=[profile?]
31         >=dev-haskell/lifted-base-0.1.2:=[profile?]
32         >=dev-haskell/network-2.6.1.0:=[profile?]
33         >=dev-haskell/old-locale-1.0.0.2:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
34         >=dev-haskell/resourcet-0.4.6:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
35         dev-haskell/streaming-commons:=[profile?]
36         >=dev-haskell/stringsearch-0.3:=[profile?] <dev-haskell/stringsearch-0.4:=[profile?]
37         >=dev-haskell/text-0.7:=[profile?]
38         >=dev-haskell/transformers-0.2.2:=[profile?]
39         dev-haskell/unix-compat:=[profile?]
40         dev-haskell/vault:=[profile?]
41         >=dev-haskell/void-0.5:=[profile?]
42         >=dev-haskell/wai-3.0.3.0:=[profile?] <dev-haskell/wai-3.3:=[profile?]
43         >=dev-haskell/wai-logger-2.0:=[profile?] <dev-haskell/wai-logger-2.3:=[profile?]
44         dev-haskell/word8:=[profile?]
45         dev-haskell/zlib:=[profile?]
46         >=dev-lang/ghc-7.4.1:=
47 "
48 DEPEND="${RDEPEND}
49         >=dev-haskell/cabal-1.8
50         test? ( >=dev-haskell/hspec-1.3
51                 dev-haskell/hunit )
52 "