dev-haskell/colour: bump up to 2.3.5
[gentoo.git] / dev-haskell / wai-app-static / wai-app-static-3.1.6.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.5.9999
7
8 CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="WAI application for static serving"
12 HOMEPAGE="https://www.yesodweb.com/book/web-application-interface"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="print"
19
20 RDEPEND=">=dev-haskell/blaze-builder-0.2.1.4:=[profile?]
21         >=dev-haskell/blaze-html-0.5:=[profile?]
22         >=dev-haskell/blaze-markup-0.5.1:=[profile?]
23         >=dev-haskell/cryptonite-0.6:=[profile?]
24         >=dev-haskell/file-embed-0.0.3.1:=[profile?]
25         dev-haskell/http-date:=[profile?]
26         >=dev-haskell/http-types-0.7:=[profile?]
27         >=dev-haskell/memory-0.7:=[profile?]
28         >=dev-haskell/mime-types-0.1:=[profile?] <dev-haskell/mime-types-0.2:=[profile?]
29         >=dev-haskell/old-locale-1.0.0.2:=[profile?]
30         >=dev-haskell/optparse-applicative-0.7:=[profile?]
31         >=dev-haskell/text-0.7:=[profile?]
32         >=dev-haskell/transformers-0.2.2:=[profile?]
33         >=dev-haskell/unix-compat-0.2:=[profile?]
34         >=dev-haskell/unordered-containers-0.2:=[profile?]
35         >=dev-haskell/wai-3.0:=[profile?] <dev-haskell/wai-3.3:=[profile?]
36         >=dev-haskell/wai-extra-3.0:=[profile?] <dev-haskell/wai-extra-3.1:=[profile?]
37         >=dev-haskell/warp-3.0.11:=[profile?] <dev-haskell/warp-3.3:=[profile?]
38         >=dev-haskell/zlib-0.5:=[profile?]
39         >=dev-lang/ghc-7.4.1:=
40 "
41 DEPEND="${RDEPEND}
42         >=dev-haskell/cabal-1.8
43         test? ( >=dev-haskell/hspec-1.3
44                 dev-haskell/mockery
45                 dev-haskell/network
46                 dev-haskell/temporary )
47 "
48
49 src_configure() {
50         haskell-cabal_src_configure \
51                 $(cabal_flag print print)
52 }