Set appropriate maintainer types in metadata.xml (GLEP 67)
[gentoo.git] / dev-haskell / unix-compat / unix-compat-0.4.1.4.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.4.9999
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 DESCRIPTION="Portable POSIX-compatibility layer"
13 HOMEPAGE="https://github.com/jystic/unix-compat"
14 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
19 IUSE="old-time"
20
21 RDEPEND=">=dev-lang/ghc-7.4.1:=
22 "
23 DEPEND="${RDEPEND}
24         >=dev-haskell/cabal-1.6
25 "
26
27 src_configure() {
28         haskell-cabal_src_configure \
29                 $(cabal_flag old-time old-time)
30 }