dev-haskell/colour: bump up to 2.3.5
[gentoo.git] / dev-haskell / tls / tls-1.2.18.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.5.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="TLS/SSL protocol native implementation (Server and Client)"
12 HOMEPAGE="https://github.com/vincenthz/hs-tls"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="amd64 x86"
18 IUSE="+compat"
19
20 RDEPEND="dev-haskell/asn1-encoding:=[profile?]
21         >=dev-haskell/asn1-types-0.2.0:=[profile?]
22         dev-haskell/async:=[profile?]
23         dev-haskell/byteable:=[profile?]
24         >=dev-haskell/cereal-0.4:=[profile?]
25         >=dev-haskell/cipher-aes-0.2:=[profile?] <dev-haskell/cipher-aes-0.3:=[profile?]
26         dev-haskell/cipher-des:=[profile?]
27         dev-haskell/cipher-rc4:=[profile?]
28         >=dev-haskell/crypto-cipher-types-0.0.8:=[profile?]
29         dev-haskell/crypto-numbers:=[profile?]
30         >=dev-haskell/crypto-pubkey-0.2.8:=[profile?]
31         >=dev-haskell/crypto-pubkey-types-0.4:=[profile?]
32         >=dev-haskell/crypto-random-0.0:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
33         >=dev-haskell/cryptohash-0.6:=[profile?]
34         dev-haskell/data-default-class:=[profile?]
35         dev-haskell/mtl:=[profile?]
36         dev-haskell/network:=[profile?]
37         dev-haskell/transformers:=[profile?]
38         >=dev-haskell/x509-1.5.0:=[profile?] <dev-haskell/x509-1.6.0:=[profile?]
39         >=dev-haskell/x509-store-1.5.0:=[profile?]
40         >=dev-haskell/x509-validation-1.5.1:=[profile?] <dev-haskell/x509-validation-1.6.0:=[profile?]
41         >=dev-lang/ghc-7.4.1:=
42 "
43 DEPEND="${RDEPEND}
44         >=dev-haskell/cabal-1.8
45         test? ( >=dev-haskell/cprng-aes-0.5
46                 dev-haskell/hourglass
47                 dev-haskell/quickcheck
48                 dev-haskell/tasty
49                 dev-haskell/tasty-quickcheck )
50 "
51
52 src_configure() {
53         haskell-cabal_src_configure \
54                 $(cabal_flag compat compat)
55 }