Merge remote-tracking branch 'remotes/github/pr/116'.
[gentoo.git] / dev-haskell / text-stream-decode / text-stream-decode-0.1.0.5.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.3.6.9999
8 #hackport: flags: +text11
9
10 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
11 inherit haskell-cabal
12
13 DESCRIPTION="Streaming decoding functions for UTF encodings. (deprecated)"
14 HOMEPAGE="https://github.com/fpco/text-stream-decode"
15 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
16
17 LICENSE="MIT"
18 SLOT="0/${PV}"
19 KEYWORDS="amd64 x86"
20 IUSE=""
21
22 RDEPEND=">=dev-haskell/text-1.1:=[profile?]
23         >=dev-lang/ghc-6.10.4:=
24 "
25 DEPEND="${RDEPEND}
26         >=dev-haskell/cabal-1.8
27         test? ( >=dev-haskell/hspec-1.8 )
28 "
29
30 src_configure() {
31         haskell-cabal_src_configure \
32                 --flag=text11
33 }