dev-haskell/*: drop alpha keywords
[gentoo.git] / dev-haskell / text / text-1.2.2.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.6.9999
7 #hackport: flags: -developer,-integer-pure
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 DESCRIPTION="An efficient packed Unicode text type"
13 HOMEPAGE="https://github.com/bos/text"
14 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
19 IUSE=""
20
21 RESTRICT=test # break cyclic dependencies
22
23 RDEPEND="dev-haskell/binary:=[profile?]
24         >=dev-lang/ghc-7.4.1:=
25 "
26 DEPEND="${RDEPEND}
27         >=dev-haskell/cabal-1.8
28         test? ( >=dev-haskell/hunit-1.2
29                 >=dev-haskell/quickcheck-2.7
30                 dev-haskell/quickcheck-unicode
31                 dev-haskell/random
32                 >=dev-haskell/test-framework-0.4
33                 >=dev-haskell/test-framework-hunit-0.2
34                 >=dev-haskell/test-framework-quickcheck2-0.2 )
35 "
36
37 src_prepare() {
38         epatch "${FILESDIR}"/${P}-integer-simple.patch
39 }
40
41 src_configure() {
42         haskell-cabal_src_configure \
43                 --flag=-developer
44 }