Merge remote-tracking branch 'github/pr/608'.
[gentoo.git] / dev-haskell / text / text-1.2.2.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.6.9999
8 #hackport: flags: -developer,-integer-pure
9
10 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
11 inherit haskell-cabal
12
13 DESCRIPTION="An efficient packed Unicode text type"
14 HOMEPAGE="https://github.com/bos/text"
15 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
16
17 LICENSE="BSD"
18 SLOT="0/${PV}"
19 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
20 IUSE=""
21
22 RESTRICT=test # break cyclic dependencies
23
24 RDEPEND="dev-haskell/binary:=[profile?]
25         >=dev-lang/ghc-7.4.1:=
26 "
27 DEPEND="${RDEPEND}
28         >=dev-haskell/cabal-1.8
29         test? ( >=dev-haskell/hunit-1.2
30                 >=dev-haskell/quickcheck-2.7
31                 dev-haskell/quickcheck-unicode
32                 dev-haskell/random
33                 >=dev-haskell/test-framework-0.4
34                 >=dev-haskell/test-framework-hunit-0.2
35                 >=dev-haskell/test-framework-quickcheck2-0.2 )
36 "
37
38 src_configure() {
39         haskell-cabal_src_configure \
40                 --flag=-developer \
41                 --flag=-integer-pure
42 }