sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / dev-haskell / test-framework-quickcheck2 / test-framework-quickcheck2-0.3.0.5-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 # ebuild generated by hackport 0.5.6.9999
7 #hackport: flags: +base4
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 DESCRIPTION="QuickCheck2 support for the test-framework package"
13 HOMEPAGE="http://haskell.github.io/test-framework/"
14 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
19 IUSE=""
20
21 RDEPEND=">=dev-haskell/extensible-exceptions-0.1.1:=[profile?] <dev-haskell/extensible-exceptions-0.2.0:=[profile?]
22         >=dev-haskell/quickcheck-2.4:2=[profile?]
23         >=dev-haskell/random-1:=[profile?] <dev-haskell/random-1.2:=[profile?]
24         >=dev-haskell/test-framework-0.8:=[profile?] <dev-haskell/test-framework-0.9:=[profile?]
25         >=dev-lang/ghc-7.4.1:=
26 "
27 DEPEND="${RDEPEND}
28         >=dev-haskell/cabal-1.10
29 "
30
31 src_prepare() {
32         default
33
34         cabal_chdeps \
35                 'QuickCheck            >= 2.4    && < 2.13' 'QuickCheck            >= 2.4'
36 }
37
38 src_configure() {
39         haskell-cabal_src_configure \
40                 --flag=base4
41 }