dev-haskell/*: drop alpha keywords
[gentoo.git] / dev-haskell / split / split-0.2.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.3.2.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="Combinator library for splitting lists"
12 HOMEPAGE="http://hackage.haskell.org/package/split"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="amd64 ia64 ppc ppc64 sparc x86 ~ppc-macos ~x86-macos"
18 IUSE=""
19
20 RDEPEND=">=dev-lang/ghc-6.10.4:="
21 DEPEND="${RDEPEND}
22                 >=dev-haskell/cabal-1.10
23                 test? ( >=dev-haskell/quickcheck-2.4
24                 )"
25
26 src_prepare() {
27         cabal_chdeps \
28                 'base <4.8' 'base'
29 }