sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / dev-haskell / skylighting / skylighting-0.1.1.5.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.5.1.9999
7 #hackport: flags: -bootstrap
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 DESCRIPTION="syntax highlighting library"
13 HOMEPAGE="https://github.com/jgm/skylighting"
14 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="executable"
20
21 RDEPEND="dev-haskell/aeson:=[profile?]
22         >=dev-haskell/blaze-html-0.5:=[profile?]
23         dev-haskell/case-insensitive:=[profile?]
24         dev-haskell/hxt:=[profile?]
25         dev-haskell/mtl:=[profile?]
26         dev-haskell/regex-pcre-builtin:=[profile?]
27         dev-haskell/safe:=[profile?]
28         dev-haskell/text:=[profile?]
29         dev-haskell/utf8-string:=[profile?]
30         >=dev-lang/ghc-7.8.2:=
31         executable? ( dev-haskell/pretty-show:=[profile?] )
32 "
33 DEPEND="${RDEPEND}
34         >=dev-haskell/cabal-1.24.2.0
35         test? ( dev-haskell/diff
36                 dev-haskell/hunit
37                 dev-haskell/random
38                 dev-haskell/tasty
39                 dev-haskell/tasty-golden
40                 dev-haskell/tasty-hunit
41                 !executable? ( dev-haskell/pretty-show ) )
42 "
43
44 src_configure() {
45         haskell-cabal_src_configure \
46                 --flag=-bootstrap \
47                 $(cabal_flag executable executable)
48 }