086e2bd902c2eec9ad7c6b2bc7120edda9c4f11b
[gentoo.git] / dev-haskell / sendfile / sendfile-0.7.11.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 # ebuild generated by hackport 0.6.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
10
11 DESCRIPTION="A portable sendfile library"
12 HOMEPAGE="http://hub.darcs.net/stepcut/sendfile"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="portable"
19
20 RDEPEND=">=dev-haskell/network-2:=[profile?] <dev-haskell/network-3.2:=[profile?]
21         >=dev-lang/ghc-7.4.1:=
22 "
23 DEPEND="${RDEPEND}
24         >=dev-haskell/cabal-1.6
25 "
26
27 src_configure() {
28         haskell-cabal_src_configure \
29                 $(cabal_flag portable portable)
30 }