Drop $Id$ per council decision in bug #611234.
[gentoo.git] / dev-haskell / semigroupoid-extras / semigroupoid-extras-5.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.5.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
10
11 DESCRIPTION="Semigroupoids that depend on PolyKinds"
12 HOMEPAGE="https://github.com/ekmett/semigroupoid-extras"
13 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+profunctors"
19
20 RDEPEND=">=dev-haskell/semigroupoids-5:=[profile?] <dev-haskell/semigroupoids-6:=[profile?]
21         >=dev-lang/ghc-7.6.1:=
22         profunctors? ( >=dev-haskell/profunctors-5:=[profile?] <dev-haskell/profunctors-6:=[profile?] )
23 "
24 DEPEND="${RDEPEND}
25         >=dev-haskell/cabal-1.16.0
26 "
27
28 src_configure() {
29         haskell-cabal_src_configure \
30                 $(cabal_flag profunctors profunctors)
31 }