dev-haskell/text-icu: amd64 x86 stable, bug #524790
[gentoo.git] / dev-haskell / resource-pool / resource-pool-0.2.3.2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.4.9999
8 #hackport: flags: -developer
9
10 CABAL_FEATURES="lib profile haddock hoogle hscolour"
11 inherit haskell-cabal
12
13 DESCRIPTION="A high-performance striped resource pooling implementation"
14 HOMEPAGE="https://github.com/bos/pool"
15 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
16
17 LICENSE="BSD"
18 SLOT="0/${PV}"
19 KEYWORDS="~amd64 ~x86"
20 IUSE=""
21
22 RDEPEND="dev-haskell/hashable:=[profile?]
23         >=dev-haskell/monad-control-0.2.0.1:=[profile?]
24         >=dev-haskell/stm-2.3:=[profile?]
25         dev-haskell/transformers:=[profile?]
26         >=dev-haskell/transformers-base-0.4:=[profile?]
27         >=dev-haskell/vector-0.7:=[profile?]
28         >=dev-lang/ghc-7.4.1:=
29 "
30 DEPEND="${RDEPEND}
31         >=dev-haskell/cabal-1.8
32 "
33
34 src_configure() {
35         haskell-cabal_src_configure \
36                 --flag=-developer
37 }