Merge github#363: sys-process/atop: add systemd support
[gentoo.git] / dev-haskell / quickcheck / quickcheck-2.8.2.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.6.9999
8 #hackport: flags: +base4,-base3,templatehaskell:template_haskell
9
10 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
11 inherit haskell-cabal
12
13 MY_PN="QuickCheck"
14 MY_P="${MY_PN}-${PV}"
15
16 DESCRIPTION="Automatic testing of Haskell programs"
17 HOMEPAGE="https://github.com/nick8325/quickcheck"
18 SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
19
20 LICENSE="BSD"
21 SLOT="2/${PV}"
22 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
23 IUSE="+template_haskell"
24
25 RESTRICT=test # to avoid test circular depends
26
27 RDEPEND="dev-haskell/random:=[profile?]
28         >=dev-haskell/tf-random-0.4:=[profile?]
29         >=dev-haskell/transformers-0.2:=[profile?]
30         >=dev-lang/ghc-7.4.1:=
31 "
32 DEPEND="${RDEPEND}
33         >=dev-haskell/cabal-1.8
34         test? ( >=dev-haskell/test-framework-0.4 <dev-haskell/test-framework-0.9 )
35 "
36
37 S="${WORKDIR}/${MY_P}"
38
39 src_configure() {
40         haskell-cabal_src_configure \
41                 --flag=-base3 \
42                 --flag=base4 \
43                 $(cabal_flag template_haskell templatehaskell)
44 }