media-gfx/entangle: Enable py3.8
[gentoo.git] / dev-haskell / primitive / primitive-0.6.1.0-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.6.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="Primitive memory-related operations"
12 HOMEPAGE="https://github.com/haskell/primitive"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
18 IUSE=""
19
20 RDEPEND=">=dev-haskell/transformers-0.2:=[profile?]
21         >=dev-lang/ghc-7.4.1:=
22 "
23 DEPEND="${RDEPEND}
24         >=dev-haskell/cabal-1.10
25 "
26
27 src_prepare() {
28         cabal_chdeps \
29                 'base >= 4.3 && < 4.9' 'base >= 4.3' \
30                 'ghc-prim >= 0.2 && < 0.5' 'ghc-prim >= 0.2' \
31                 'transformers >= 0.2 && < 0.5' 'transformers >= 0.2'
32 }