proj/gentoo: Initial commit
[gentoo.git] / dev-haskell / primitive / primitive-0.5.4.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.4.9999
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 DESCRIPTION="Primitive memory-related operations"
13 HOMEPAGE="https://github.com/haskell/primitive"
14 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
19 IUSE=""
20
21 RDEPEND=">=dev-lang/ghc-7.4.1:=
22 "
23 DEPEND="${RDEPEND}
24         >=dev-haskell/cabal-1.10
25 "
26
27 src_prepare() {
28         cabal_chdeps \
29                 'ghc-prim >= 0.2 && < 0.4' 'ghc-prim >= 0.2 && < 0.5'
30 }