dev-haskell/terminfo: allow ghc-8
[gentoo.git] / dev-haskell / persistent-sqlite / persistent-sqlite-2.6.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 # ebuild generated by hackport 0.5.9999
8 #hackport: flags: +systemlib
9
10 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
11 inherit haskell-cabal
12
13 DESCRIPTION="Backend for the persistent library using sqlite3"
14 HOMEPAGE="http://www.yesodweb.com/book/persistent"
15 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
16
17 LICENSE="MIT"
18 SLOT="0/${PV}"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="build-sanity-exe"
21
22 RDEPEND=">=dev-db/sqlite-3.0
23         >=dev-haskell/aeson-0.6.2:=[profile?]
24         >=dev-haskell/conduit-0.5.3:=[profile?]
25         >=dev-haskell/monad-control-0.2:=[profile?]
26         >=dev-haskell/monad-logger-0.2.4:=[profile?]
27         dev-haskell/old-locale:=[profile?]
28         >=dev-haskell/persistent-2.6:=[profile?] <dev-haskell/persistent-3:=[profile?]
29         dev-haskell/resource-pool:=[profile?]
30         >=dev-haskell/resourcet-1.1:=[profile?]
31         >=dev-haskell/text-0.7:=[profile?]
32         >=dev-lang/ghc-7.8.2:=
33         virtual/libc
34 "
35 DEPEND="${RDEPEND}
36         >=dev-haskell/cabal-1.18.1.3
37         test? ( dev-haskell/hspec
38                 dev-haskell/persistent-template
39                 dev-haskell/temporary )
40 "
41
42 src_configure() {
43         haskell-cabal_src_configure \
44                 $(cabal_flag build-sanity-exe build-sanity-exe) \
45                 --flag=systemlib
46 }