dev-haskell/pandoc-citeproc: convert IUSE underscore to dash
[gentoo.git] / dev-haskell / pandoc-citeproc / pandoc-citeproc-0.7.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.5.9999
7 #hackport: flags: -small_base
8
9 CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 DESCRIPTION="Supports using pandoc with citeproc"
13 HOMEPAGE="http://hackage.haskell.org/package/pandoc-citeproc"
14 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="amd64 x86"
19 IUSE="+bibutils debug embed-data-files test-citeproc unicode_collation"
20
21 RESTRICT=test # fd:8: hClose: resource vanished (Broken pipe)
22
23 RDEPEND=">=app-text/pandoc-1.13:=[profile?]
24         >=dev-haskell/aeson-0.7:=[profile?] <dev-haskell/aeson-0.10:=[profile?]
25         dev-haskell/aeson-pretty:=[profile?]
26         dev-haskell/attoparsec:=[profile?]
27         dev-haskell/data-default:=[profile?]
28         dev-haskell/mtl:=[profile?]
29         dev-haskell/old-locale:=[profile?]
30         >=dev-haskell/pandoc-types-1.12.3:=[profile?]
31         dev-haskell/parsec:=[profile?]
32         >=dev-haskell/setenv-0.1:=[profile?] <dev-haskell/setenv-0.2:=[profile?]
33         dev-haskell/split:=[profile?]
34         dev-haskell/syb:=[profile?]
35         dev-haskell/tagsoup:=[profile?]
36         >=dev-haskell/temporary-1.1:=[profile?]
37         dev-haskell/text:=[profile?]
38         >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.11:=[profile?]
39         >=dev-haskell/xml-conduit-1.2:=[profile?] <dev-haskell/xml-conduit-1.4:=[profile?]
40         >=dev-haskell/yaml-0.8.8.7:=[profile?]
41         >=dev-lang/ghc-7.4.1:=
42         bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
43         debug? ( dev-haskell/pretty-show:=[profile?] )
44         unicode_collation? ( dev-haskell/text-icu:=[profile?] )
45         !unicode_collation? ( dev-haskell/rfc5051:=[profile?] )
46 "
47 DEPEND="${RDEPEND}
48         >=dev-haskell/cabal-1.12
49 "
50
51 src_prepare() {
52         epatch "${FILESDIR}"/${PN}-0.9-no-binutils.patch
53 }
54
55 src_configure() {
56         haskell-cabal_src_configure \
57                 $(cabal_flag bibutils bibutils) \
58                 $(cabal_flag debug debug) \
59                 $(cabal_flag embed-data-files embed_data_files) \
60                 --flag=-small_base \
61                 $(cabal_flag test-citeproc test-citeproc) \
62                 $(cabal_flag unicode_collation unicode_collation)
63 }