Merge remote-tracking branch 'github/pr/107'
[gentoo.git] / dev-haskell / pandoc-citeproc / pandoc-citeproc-0.7.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.5.9999
8 #hackport: flags: -small_base
9
10 CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
11 inherit haskell-cabal
12
13 DESCRIPTION="Supports using pandoc with citeproc"
14 HOMEPAGE="http://hackage.haskell.org/package/pandoc-citeproc"
15 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
16
17 LICENSE="BSD"
18 SLOT="0/${PV}"
19 KEYWORDS="amd64 x86"
20 IUSE="+bibutils debug embed_data_files test_citeproc unicode_collation"
21
22 RESTRICT=test # fd:8: hClose: resource vanished (Broken pipe)
23
24 RDEPEND=">=app-text/pandoc-1.13:=[profile?]
25         >=dev-haskell/aeson-0.7:=[profile?] <dev-haskell/aeson-0.10:=[profile?]
26         dev-haskell/aeson-pretty:=[profile?]
27         dev-haskell/attoparsec:=[profile?]
28         dev-haskell/data-default:=[profile?]
29         dev-haskell/mtl:=[profile?]
30         dev-haskell/old-locale:=[profile?]
31         >=dev-haskell/pandoc-types-1.12.3:=[profile?]
32         dev-haskell/parsec:=[profile?]
33         >=dev-haskell/setenv-0.1:=[profile?] <dev-haskell/setenv-0.2:=[profile?]
34         dev-haskell/split:=[profile?]
35         dev-haskell/syb:=[profile?]
36         dev-haskell/tagsoup:=[profile?]
37         >=dev-haskell/temporary-1.1:=[profile?]
38         dev-haskell/text:=[profile?]
39         >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.11:=[profile?]
40         >=dev-haskell/xml-conduit-1.2:=[profile?] <dev-haskell/xml-conduit-1.4:=[profile?]
41         >=dev-haskell/yaml-0.8.8.7:=[profile?]
42         >=dev-lang/ghc-7.4.1:=
43         bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
44         debug? ( dev-haskell/pretty-show:=[profile?] )
45         unicode_collation? ( dev-haskell/text-icu:=[profile?] )
46         !unicode_collation? ( dev-haskell/rfc5051:=[profile?] )
47 "
48 DEPEND="${RDEPEND}
49         >=dev-haskell/cabal-1.12
50 "
51
52 src_configure() {
53         haskell-cabal_src_configure \
54                 $(cabal_flag bibutils bibutils) \
55                 $(cabal_flag debug debug) \
56                 $(cabal_flag embed_data_files embed_data_files) \
57                 --flag=-small_base \
58                 $(cabal_flag test_citeproc test_citeproc) \
59                 $(cabal_flag unicode_collation unicode_collation)
60 }