dev-haskell/syb: bump up to 0.7.1
[gentoo.git] / dev-haskell / pandoc-citeproc / pandoc-citeproc-0.3.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.9999
7 #hackport: flags: -small_base
8
9 CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 DESCRIPTION="Supports using pandoc with citeproc"
13 HOMEPAGE="http://hackage.haskell.org/package/pandoc-citeproc"
14 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="+bibutils embed-data-files +hexpat +network test-citeproc unicode_collation"
20 RESTRICT="!test? ( test )"
21
22 RDEPEND=">=app-text/pandoc-1.12.1:=[profile?]
23         dev-haskell/aeson:=[profile?]
24         dev-haskell/aeson-pretty:=[profile?]
25         dev-haskell/attoparsec:=[profile?]
26         dev-haskell/mtl:=[profile?]
27         >=dev-haskell/pandoc-types-1.12.3:=[profile?]
28         dev-haskell/parsec:=[profile?]
29         dev-haskell/split:=[profile?]
30         dev-haskell/syb:=[profile?]
31         dev-haskell/tagsoup:=[profile?]
32         >=dev-haskell/temporary-1.1:=[profile?]
33         >=dev-haskell/texmath-0.6.4:=[profile?]
34         dev-haskell/text:=[profile?]
35         >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.11:=[profile?]
36         >=dev-haskell/yaml-0.8.8.2:=[profile?]
37         >=dev-lang/ghc-7.4.1:=
38         bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
39         hexpat? ( >=dev-haskell/hexpat-0.20.2:=[profile?] )
40         !hexpat? ( dev-haskell/xml:=[profile?] )
41         network? ( >=dev-haskell/http-4000.0.9:=[profile?]
42                         >=dev-haskell/network-2:=[profile?]
43                         dev-haskell/network-uri:=[profile?] )
44         unicode_collation? ( dev-haskell/text-icu:=[profile?] )
45         !unicode_collation? ( dev-haskell/rfc5051:=[profile?] )
46 "
47 DEPEND="${RDEPEND}
48         >=dev-haskell/cabal-1.12
49         test? ( >=app-text/pandoc-1.12.1
50                 dev-haskell/aeson
51                 >=dev-haskell/pandoc-types-1.12.3
52                 dev-haskell/text
53                 >=dev-haskell/yaml-0.8.8.2 )
54 "
55
56 src_prepare() {
57         cabal_chdeps \
58                 'network >= 2,' 'network >= 2, network-uri,'
59 }
60
61 src_configure() {
62         # workaround bug on ghc-7.6.3:
63         # > [13 of 24] Compiling Text.CSL.Input.Bibtex ...
64         # > stack overflow: use +RTS -K<size> to increase it
65         [[ $(ghc-version) == 7.6.* ]] && replace-hcflags -O[2-9] -O1
66         [[ $(ghc-version) == 7.8.* ]] && replace-hcflags -O[2-9] -O1
67
68         haskell-cabal_src_configure \
69                 $(cabal_flag bibutils bibutils) \
70                 $(cabal_flag embed-data-files embed_data_files) \
71                 $(cabal_flag hexpat hexpat) \
72                 $(cabal_flag network network) \
73                 --flag=-small_base \
74                 $(cabal_flag test-citeproc test_citeproc) \
75                 $(cabal_flag unicode_collation unicode_collation)
76 }