dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-haskell / pandoc-citeproc / pandoc-citeproc-0.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.3.5.9999
7
8 CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="Supports using pandoc with citeproc"
12 HOMEPAGE="http://hackage.haskell.org/package/pandoc-citeproc"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+bibutils embed-data-files +hexpat +network +small-base unicode_collation"
19 RESTRICT=test # missing files: locales-en-US.xml: openBinaryFile
20
21 RDEPEND=">=app-text/pandoc-1.12.1:=[profile?]
22         dev-haskell/aeson:=[profile?]
23         dev-haskell/aeson-pretty:=[profile?]
24         dev-haskell/attoparsec:=[profile?]
25         dev-haskell/mtl:=[profile?]
26         >=dev-haskell/pandoc-types-1.12.3:=[profile?]
27         dev-haskell/parsec:=[profile?]
28         dev-haskell/split:=[profile?]
29         dev-haskell/syb:=[profile?]
30         dev-haskell/tagsoup:=[profile?]
31         >=dev-haskell/temporary-1.1:=[profile?]
32         >=dev-haskell/texmath-0.6.4:=[profile?]
33         dev-haskell/text:=[profile?]
34         >=dev-haskell/vector-0.10:=[profile?] <dev-haskell/vector-0.11:=[profile?]
35         >=dev-haskell/yaml-0.8:=[profile?]
36         >=dev-lang/ghc-7.0.1:=
37         bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
38         hexpat? ( >=dev-haskell/hexpat-0.20.2:=[profile?] )
39         !hexpat? ( dev-haskell/xml:=[profile?] )
40         network? ( >=dev-haskell/http-4000.0.9:=[profile?]
41                         >=dev-haskell/network-2:=[profile?] )
42         unicode_collation? ( dev-haskell/text-icu:=[profile?] )
43         !unicode_collation? ( dev-haskell/rfc5051:=[profile?] )
44 "
45 DEPEND="${RDEPEND}
46         >=dev-haskell/cabal-1.12
47 "
48
49 src_configure() {
50         # workaround bug on ghc-7.6.3:
51         # > [13 of 24] Compiling Text.CSL.Input.Bibtex ...
52         # > stack overflow: use +RTS -K<size> to increase it
53         replace-hcflags -O[2-9] -O1
54
55         haskell-cabal_src_configure \
56                 $(cabal_flag bibutils bibutils) \
57                 $(cabal_flag embed-data-files embed_data_files) \
58                 $(cabal_flag hexpat hexpat) \
59                 $(cabal_flag network network) \
60                 $(cabal_flag small-base small_base) \
61                 $(cabal_flag unicode_collation unicode_collation)
62 }