dev-haskell/colour: bump up to 2.3.5
[gentoo.git] / dev-haskell / openglraw / openglraw-3.2.4.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.5.1.9999
7 #hackport: flags: -usenativewindowslibraries,-useglxgetprocaddress,-osandroid,-usegles2
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour"
10 inherit haskell-cabal
11
12 MY_PN="OpenGLRaw"
13 MY_P="${MY_PN}-${PV}"
14
15 DESCRIPTION="A raw binding for the OpenGL graphics system"
16 HOMEPAGE="http://www.haskell.org/haskellwiki/Opengl"
17 SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
18
19 LICENSE="BSD"
20 SLOT="0/${PV}"
21 KEYWORDS="~amd64 ~x86"
22 IUSE=""
23
24 RDEPEND=">=dev-haskell/fixed-0.2:=[profile?] <dev-haskell/fixed-0.3:=[profile?]
25         >=dev-haskell/half-0.2.2.1:=[profile?] <dev-haskell/half-0.3:=[profile?]
26         >=dev-haskell/text-0.1:=[profile?] <dev-haskell/text-1.3:=[profile?]
27         >=dev-lang/ghc-7.8.2:=
28         virtual/opengl
29 "
30 DEPEND="${RDEPEND}
31         >=dev-haskell/cabal-1.18.1.3
32 "
33
34 S="${WORKDIR}/${MY_P}"
35
36 src_configure() {
37         haskell-cabal_src_configure \
38                 --flag=-osandroid \
39                 --flag=-usegles2 \
40                 --flag=-useglxgetprocaddress \
41                 --flag=-usenativewindowslibraries
42 }