Drop $Id$ per council decision in bug #611234.
[gentoo.git] / dev-haskell / mono-traversable / mono-traversable-1.0.1.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.5.1.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="Type classes for mapping, folding, and traversing monomorphic containers"
12 HOMEPAGE="https://github.com/snoyberg/mono-traversable"
13 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND="dev-haskell/hashable:=[profile?]
21         >=dev-haskell/semigroups-0.10:=[profile?]
22         >=dev-haskell/split-0.2:=[profile?]
23         >=dev-haskell/text-0.11:=[profile?]
24         >=dev-haskell/unordered-containers-0.2:=[profile?]
25         >=dev-haskell/vector-0.10:=[profile?]
26         >=dev-haskell/vector-algorithms-0.6:=[profile?]
27         >=dev-lang/ghc-7.8.2:=
28 "
29 DEPEND="${RDEPEND}
30         >=dev-haskell/cabal-1.18.1.3
31         test? ( dev-haskell/foldl
32                 dev-haskell/hspec
33                 dev-haskell/hunit
34                 dev-haskell/quickcheck )
35 "