dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-haskell / lifted-async / lifted-async-0.8.0.1-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.7.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="Run lifted IO operations asynchronously and wait for their results"
12 HOMEPAGE="https://github.com/maoe/lifted-async"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+monad-control-1"
19
20 RDEPEND=">=dev-haskell/async-2.0.1:=[profile?] <dev-haskell/async-2.2:=[profile?]
21         >=dev-haskell/lifted-base-0.2:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
22         >=dev-haskell/transformers-base-0.4:=[profile?] <dev-haskell/transformers-base-0.5:=[profile?]
23         >=dev-lang/ghc-7.4.1:=
24         monad-control-1? ( >=dev-haskell/constraints-0.2:=[profile?]
25                                 >=dev-haskell/monad-control-1.0:=[profile?] <dev-haskell/monad-control-1.1:=[profile?] )
26         !monad-control-1? ( >=dev-haskell/monad-control-0:=[profile?] <dev-haskell/monad-control-1:=[profile?] )
27 "
28 DEPEND="${RDEPEND}
29         >=dev-haskell/cabal-1.8
30         test? ( dev-haskell/hunit
31                 dev-haskell/mtl
32                 dev-haskell/tasty
33                 >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
34                 dev-haskell/tasty-th )
35 "
36
37 src_configure() {
38         haskell-cabal_src_configure \
39                 $(cabal_flag monad-control-1 monad-control-1)
40 }