dev-haskell/lifted-async: bump up to 0.7.0.2
[gentoo.git] / dev-haskell / lifted-async / lifted-async-0.7.0.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 # ebuild generated by hackport 0.4.6.9999
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 DESCRIPTION="Run lifted IO operations asynchronously and wait for their results"
13 HOMEPAGE="https://github.com/maoe/lifted-async"
14 SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="+monad-control-1"
20
21 RDEPEND=">=dev-haskell/async-2.0.1:=[profile?] <dev-haskell/async-2.1:=[profile?]
22         >=dev-haskell/lifted-base-0.2:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
23         >=dev-haskell/transformers-base-0.4:=[profile?] <dev-haskell/transformers-base-0.5:=[profile?]
24         >=dev-lang/ghc-7.4.1:=
25         monad-control-1? ( >=dev-haskell/constraints-0.2:=[profile?] <dev-haskell/constraints-0.6:=[profile?]
26                                 >=dev-haskell/monad-control-1.0:=[profile?] <dev-haskell/monad-control-1.1:=[profile?] )
27         !monad-control-1? ( >=dev-haskell/monad-control-0:=[profile?] <dev-haskell/monad-control-1:=[profile?] )
28 "
29 DEPEND="${RDEPEND}
30         >=dev-haskell/cabal-1.8
31         test? ( dev-haskell/hunit
32                 dev-haskell/mtl
33                 dev-haskell/tasty
34                 >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
35                 dev-haskell/tasty-th )
36 "
37
38 src_configure() {
39         haskell-cabal_src_configure \
40                 $(cabal_flag monad-control-1 monad-control-1)
41 }