dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-haskell / lifted-async / lifted-async-0.2.0.2-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 # ebuild generated by hackport 0.4.3.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
9 inherit base haskell-cabal
10
11 DESCRIPTION="Run lifted IO operations asynchronously and wait for their results"
12 HOMEPAGE="https://github.com/maoe/lifted-async"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="BSD"
16 SLOT="0/${PV}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19 RESTRICT="test" # patch has a test failure: withAsync waitEither : FAIL
20
21 RDEPEND=">=dev-haskell/async-2.0.1:=[profile?]
22         >=dev-haskell/lifted-base-0.2:=[profile?]
23         >=dev-haskell/monad-control-0.3.1:=[profile?]
24         >=dev-haskell/transformers-base-0.4:=[profile?]
25         >=dev-lang/ghc-7.4.1:=
26 "
27 DEPEND="${RDEPEND}
28         >=dev-haskell/cabal-1.8
29         test? ( dev-haskell/hunit
30                 dev-haskell/mtl
31                 dev-haskell/tasty
32                 >=dev-haskell/tasty-hunit-0.9 <dev-haskell/tasty-hunit-0.10
33                 dev-haskell/tasty-th )
34 "
35
36 PATCHES=("${FILESDIR}/${PN}-0.2.0.2-monad-control-1.1.patch")