dev-haskell/bytes: bump up to 0.15.5
[gentoo.git] / dev-haskell / lhs2tex / lhs2tex-1.18.1-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 CABAL_FEATURES="bin"
7 inherit base haskell-cabal
8
9 DESCRIPTION="Preprocessor for typesetting Haskell sources with LaTeX"
10 HOMEPAGE="http://www.andres-loeh.de/lhs2tex/"
11 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 # dev-texlive/texlive-mathscience contains 'stmaryrd' font used
19 # for guide generation
20 RDEPEND=">=dev-tex/polytable-0.8.2
21         dev-texlive/texlive-mathscience"
22
23 DEPEND="${RDEPEND}
24                 >=dev-haskell/cabal-1.10
25                 dev-haskell/mtl
26                 dev-haskell/regex-compat
27                 >=dev-lang/ghc-6.12.1"
28
29 # Setup.hs uses 'Text.Regex' available in both 'r-c' and 'r-c-tdfa'
30 HCFLAGS+=" -ignore-package=regex-compat-tdfa"
31
32 # datadir is /usr/share/${PN}/${GHC_VER} so mandir is ${DATADIR}/../../man
33 PATCHES=("${FILESDIR}/${PN}-1.18.1-mandir.patch")