dev-qt/qtpositioning: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-haskell / language-c / language-c-0.7.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.5.4.9999
7 #hackport: flags: -allwarnings,+usebytestrings
8
9 CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
10 inherit haskell-cabal
11
12 DESCRIPTION="Analysis and generation of C code"
13 HOMEPAGE="https://visq.github.io/language-c/"
14 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0/${PV}"
18 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
19 IUSE=""
20
21 RDEPEND="dev-haskell/syb:=[profile?]
22         >=dev-lang/ghc-7.4.1:=
23 "
24 DEPEND="${RDEPEND}
25         dev-haskell/alex
26         >=dev-haskell/cabal-1.8
27         dev-haskell/happy
28 "
29
30 src_configure() {
31         haskell-cabal_src_configure \
32                 --flag=-allwarnings \
33                 --flag=usebytestrings
34 }