dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / dev-haskell / icalendar / icalendar-0.4.0.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.5.9999
7
8 CABAL_FEATURES="lib profile haddock hoogle hscolour"
9 inherit haskell-cabal
10
11 MY_PN="iCalendar"
12 MY_P="${MY_PN}-${PV}"
13
14 DESCRIPTION="iCalendar data types, parser, and printer"
15 HOMEPAGE="https://github.com/chrra/iCalendar"
16 SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
17
18 LICENSE="BSD"
19 SLOT="0/${PV}"
20 KEYWORDS="~amd64 ~x86"
21 IUSE="+network-uri"
22
23 RDEPEND=">=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
24         >=dev-haskell/case-insensitive-0.4:=[profile?]
25         >=dev-haskell/data-default-0.3:=[profile?]
26         >=dev-haskell/mime-0.4.0.2:=[profile?]
27         >=dev-haskell/mtl-2.1.0:=[profile?]
28         dev-haskell/old-locale:=[profile?]
29         >=dev-haskell/parsec-3.1.0:=[profile?]
30         dev-haskell/text:=[profile?]
31         >=dev-lang/ghc-7.10.1:=
32         network-uri? ( >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-2.7:=[profile?]
33                         >=dev-haskell/network-uri-2.6:=[profile?] )
34         !network-uri? ( >=dev-haskell/network-2.4:=[profile?] <dev-haskell/network-2.6:=[profile?] )
35 "
36 DEPEND="${RDEPEND}
37         >=dev-haskell/cabal-1.22.2.0
38 "
39
40 S="${WORKDIR}/${MY_P}"
41
42 src_configure() {
43         haskell-cabal_src_configure \
44                 $(cabal_flag network-uri network-uri)
45 }